Trending Games | ArcheAge | Guild Wars 2 | WildStar | World of Warcraft

  Network:  FPSguru RTSguru
Login:  Password:   Remember?  
Show Quick Gamelist Jump to Random Game
Members:2,785,820 Users Online:0
Games:723  Posts:6,192,964

Member Photo Galleries

Wonderful ESO Patch
4 people rated this!
1 Bump / 3 Buries

Most Recent images uploaded by DMKano | View All

reillan writes: I found that deleting the .version file that starts with "bethesda" (I don't remember the rest of the name) fixed it for me Wed Apr 16 2014 9:40AM Report
wicked357 writes: Yes the .version file in the launcher folder then relaunch the launcher let it update then should work at least it did for me. Wed Apr 16 2014 6:01PM Report
wicked357 writes: Yes the .version file in the launcher folder then relaunch the launcher let it update then should work at least it did for me. Wed Apr 16 2014 6:01PM Report
DMKano writes: Thanks for the tips - simply fixed it by running eso.exe and not using the launcher period (because my client is up to date and repair breaks it to where I had to reinstall the whole client) Wed Apr 16 2014 7:40PM Report
reillan writes: well, that's not really "fixing" it, as eventually you'll need to use the launcher to update :) Thu Apr 17 2014 3:21PM Report
DMKano writes:

Well they fixed the launcher so now it works for everyone - including me.

The issue was on Zenimax side the whole time (bad pool of AWS IPs)

Thu Apr 17 2014 8:29PM Report

MMORPG.com writes:
Login or Register to post a comment

Special Offers