Trending Games | Magerealm | Continent of the Ninth Seal | Final Fantasy XIV: A Realm Reborn | Guild Wars 2

    Facebook Twitter YouTube
Login:  Password:   Remember?  
Show Quick Gamelist Jump to Random Game
Members:2,996,347 Users Online:0
Games:841  Posts:6,462,140
Webzen Inc. | Play Now
Action RPG | Setting:Fantasy | Status:Final  (rel 07/11/12)  | Pub:Webzen Inc.
PVP:Yes | Distribution:Download | Retail Price:n/a | Pay Type:Free | Monthly Fee:n/a
System Req: PC | Out of date info? Let us know!

Continent of the Ninth (C9) Forum » General Discussion » Why do companies insist on....

4 posts found

Advanced Member

Joined: 9/13/07
Posts: 1945

OP  6/28/12 9:35:43 AM#1

retarted installers/launchers for thier games? This webzen "hub" thing is not only irritating but broken. I keep getting spammed to install adobe flash player....uh it is and up to date. I try to play and it wants me to download some installer....uh already installed your client. Cant get past either of thoes and the "help" section is about as usefull as a pile of dog shit. When will these companies learn that yea, I may be willing to try thier game. Yea I may like it and spend money on it. But no, I'm not going to hassle with broken installers/launchers.

  User Deleted
6/28/12 3:54:43 PM#2

I had a similar situation; same thing with the C9 hub, being told my flashplayer was out-of-date though it wasn't and being encouraged to used a third party-installer (which you shouldn't dl btw).

My main problem tho was that I saved the client to my a C:Program folder but the game client didn't show up in the folder. I also couldn't find the client when I did a window's search for it in the C:Program folder that I saved it to.

Then I tried searching for it using the start menu's search by typing "global" and it showed up and I deleted it.

I then redownload the client and saved it to my Downloads folder instead of a C:Program folder ans was then able to install and play the game without further problems. Also, make sure to save a short-cut to desktop to eliminate anymore frustrations.


Must say though this is the weirdest install I've ever experienced. It felt at some points that I was installing things in order to install things in order to install things. lol


Novice Member

Joined: 3/09/12
Posts: 18

6/28/12 3:58:59 PM#3

Yah, i was fine with it until it launched nearly everytime I opened my browser in general (not just for C9). I deleted the main 'overwolf' folder, and it persisted to launch! Went through windows program uninstall, still launched. Finally searched for the exe and got rid of it for good. It's not needed for C9 to work, as it's a third-party add-on.


Novice Member

Joined: 4/10/08
Posts: 11

6/30/12 11:41:19 AM#4

Have u tried starting it up through internet explore?

should make extra files easy to install and u should be able to use different browser after the first time