Trending Games | Wizard101 | Warhammer 40K: Eternal Crusade | Cabal 2 | Star Trek Online

    Facebook Twitter YouTube
Login:  Password:   Remember?  
Show Quick Gamelist Jump to Random Game
Members:2,995,639 Users Online:0
Games:836  Posts:6,459,866
Atlus Online | Official Site
MMORPG | Setting:Fantasy | Status:Final  (rel 02/15/11)  | Pub:Marvelous USA
PVP:Yes | Distribution:Download | Retail Price:Free | Pay Type:Free | Monthly Fee:Free
System Req: PC | Out of date info? Let us know!

Pandora Saga Forum » General Discussion » Can't play Pandora Saga cause of 64 bit system

9 posts found

Novice Member

Joined: 8/08/08
Posts: 9

OP  1/07/11 1:18:20 PM#1

As the title states beta client has a prob with 64 bit systems. I'm sure they are working on it..hopefully, but not a good start, as in closed beta was np , something was overlooked.


Novice Member

Joined: 8/06/08
Posts: 53

1/07/11 6:22:48 PM#2

the CB client didn't reall install the game, it just unpacked it into a file, so thats probably why it didn't have any issues.


sucks for the 64 bit Os users out there, thank god I still forrl with my trusty XP.


Novice Member

Joined: 10/24/06
Posts: 80

1/09/11 3:46:02 AM#3

It's instaling fine for me on Win7 x64.....

Downloaded the [object Window]Downloader[object Window] i like to call them. Ran the first exe it unpacked a few things now it[object Window]s downloading the files which will take about an hour or so...

[object Window]

Meh guess your right, finished downloading and it won[object Window]t run after I click play. Tried compatibility mode ect...


Novice Member

Joined: 4/26/10
Posts: 867

Hai2u o/

1/09/11 10:58:27 AM#4

Im 64bit too.. Oh well.. Chalk up another open beta ill pass on.

Currently Playing:
Rift + Starcraft II + Gears Of War 3 Beta


Apprentice Member

Joined: 4/29/05
Posts: 280

1/09/11 11:04:25 AM#5
Originally posted by Hellfyre420

Im 64bit too.. Oh well.. Chalk up another open beta ill pass on.

You're not missing much. I played PS when it was under a different company (myRosso). You'll get more from playing Lineage 2.


Advanced Member

Joined: 3/15/04
Posts: 238

1/09/11 11:08:36 AM#6

I had this problem too, so I tried it on my laptop.  Didn't take me long to uninstall.  Game is trash.


Novice Member

Joined: 8/06/08
Posts: 53

1/10/11 4:39:55 PM#7

no it's not, just give them some time to fix the problem. it's only the launcher thats bugged, the game itself runs fine in a 64 bit OS.


if your really desperate to play, look for a hidden fole in the pandora saga folder names "_Boot.EXE" and run that after using the launcher to update.


Novice Member

Joined: 5/14/09
Posts: 42

1/10/11 5:59:30 PM#8

Its not working even with that hiddent Boot.exe... It just opens launcher and when I click play nothing happens.


Novice Member

Joined: 1/31/04
Posts: 533

8/02/11 2:56:00 PM#9

Just to let you all know that the "Nothing happens when you click play button" issue is STILL going strong.

DL'd and installed a fresh copy this morning, still doesn't work at all