Trending Games | Elder Scrolls Online | World of Warcraft | Marvel Heroes | EverQuest

  Network:  FPSguru RTSguru
Login:  Password:   Remember?  
Show Quick Gamelist Jump to Random Game
Members:2,902,077 Users Online:0
Games:753  Posts:6,274,856
Funcom | Play Now
MMORPG | Genre:Real Life | Status:Final  (rel 07/03/12)  | Pub:Funcom
PVP:Yes | Distribution:Download,Retail | Retail Price:$30.00 | Pay Type:Hybrid | Monthly Fee:n/a
System Req: PC | Out of date info? Let us know!

The Secret World Forum » General Discussion » Game engine today...still sluggish ?

12 posts found
  Xepherd

Novice Member

Joined: 1/11/11
Posts: 99

 
OP  5/27/13 3:14:51 PM#1

Hello,

One stupid question...

I loved this game, but what killed it for me was when I was in London, everything was lagging like hell (between 4 to 7 FPS sometimes, 14 was the maximum), otherwise decent framerate everywhere (GTX 570) I'd like to know if Funcom did any improvement since release?

Thanks in advance!

xepherd Xfire Miniprofile
  Bloodlust221

Apprentice Member

Joined: 10/16/04
Posts: 91

5/27/13 10:49:56 PM#2
I have been playing since beta and i have to say they have done some serious improvements towards the game..... i felt your anger when i was in london aswell... but my common framerate nowadays is about 20 - 30 (i have the shittiest computer on the planet)
  Warjin

Apprentice Member

Joined: 10/25/09
Posts: 1208

6/05/13 12:57:55 PM#3
Originally posted by Elfahiar

Hello,

One stupid question...

I loved this game, but what killed it for me was when I was in London, everything was lagging like hell (between 4 to 7 FPS sometimes, 14 was the maximum), otherwise decent framerate everywhere (GTX 570) I'd like to know if Funcom did any improvement since release?

Thanks in advance!

In some places yes, you get get major FPS drops.

  Pekish79

Novice Member

Joined: 10/27/06
Posts: 90

6/05/13 4:02:46 PM#4

dipend how you play it...

 

dx9? dx11? on window7 on window8? 64bit? 32bit? full screen? windowed?

 

i can tell you that it change more depending on those then ur pc.

 

first of all if you play window8 forget DX11 is still not working properly it's better then it was before but still quite bad

if you play window7 u can play easily DX11 maybe if full screen lag try to play in window and see how it goes...

if like me u are using W8 and u dont wanna go back to W7 the only realistic way is playing DX9... and personally i play not full screen as i pvp a lot and that's really the way to get the most FPS

 

other then that i keep everything 3.8 expect particle effect to 2.0 this as i said because i mainly PVP in PVE i could keep everything at 4.0 with particle at 3.8 easily

 

  Lugors

Advanced Member

Joined: 10/06/12
Posts: 177

6/10/13 7:42:50 PM#5

I recently got a GeForce Titan, and the game still bogs down to 7 to 12 FPS in London or Blue Mountains.  They have something very poorly optimized from the graphics engine standpoint.

  lizardbones

Elite Member

Joined: 6/11/08
Posts: 10920

I think with my heart and move with my head.-Kongos

6/10/13 7:57:00 PM#6

Turn off the shadows and use DX11 if possible. I have an AMD 5770 and these two changes made a world of difference. I'm not even sure the 5770 supports dx11 properly, but it made a big difference in performance.

** ** **

The 5770 supports DX 11.

I can not remember winning or losing a single debate on the internet.

  Pekish79

Novice Member

Joined: 10/27/06
Posts: 90

6/10/13 10:17:26 PM#7

with titan 7-12fps there is something wrong but what i can tell you for my experience i tried the game with several different computers

 

Window8+nvidia > dx9

Window7+nvidia > dx11

Window7/8 + ati > dx11

 

remember to keep the particle effect lower then 4.0 and personally i keep them at 2.0 

  kevjards

Advanced Member

Joined: 9/27/10
Posts: 1448

6/10/13 10:21:18 PM#8
have the NVidia 560ti and I have no probs when in London..getting standard 40fps..which kind of suprises me.
  Gorwe

Elite Member

Joined: 9/16/11
Posts: 1847

6/17/13 6:52:23 PM#9
Yes. It still is very much sluggish and derpy.

I've got Gigabyte ATi radeon HD7850 2GB super OC or sth like that with 8gb RAM, i5 3570k and am playing on 1680*1050. DirectX is set to 11 and Tesselation and SSAO as well as AA is turned off(I run AA from ccc). What are my frames?

Lousy 25-35 fps in Kingsmouth. It goes maybe up to 45 and as low as 20 fps throughout the game.

This is the only thing that stinks in TSW imo.
  Swordguy

Apprentice Member

Joined: 7/04/12
Posts: 5

6/23/13 8:34:23 AM#10

Although the game is poorly optimized in many areas, places like blue mountain and Illuminati  HQ will bring even the best systems to a screeching halt. this is solved by setting effect details to anything less then 4 (3.8 even).

 

For beta, and up until a month ago, I was using a 500 series nvidia card with 1 GB or video ram. although the game would run at decent FPS, the slowdowns and stuttering was brutal in some areas. about a month ago i upgraded and now have 3GB of video ram, and aside from no longer getting any slow downs, I notice that many playfields in tsw use more then 1GB or video ram, like London that will almost use 2GB.  for me, that was my bottleneck before, but other things like system Ram speeds, CPU,  storage speeds may factor in.

  ChromeBallz

Advanced Member

Joined: 5/31/04
Posts: 275

6/26/13 7:36:15 AM#11

The game relies on a good CPU more than GPU.

There's really no point to use a Geforce Titan with an ancient Celeron CPU.

Playing: EVE
Played (more than 1 month): WoW, Tera, GW2, L2, WAR, AoC, DnL, GW, LotRO, EQ2, TOR, CoH, STO, TSW
Tried (trial, up to 1 month): EQ, UO, AO, EnB, TCoS, Fury, Ryzom, EU, DDO, TR, RF, CO, Aion, VG

  invizo

Novice Member

Joined: 1/18/06
Posts: 42

6/27/13 9:46:07 AM#12
With a decent quad core, 2gb of VRAM (like a 660Ti gtx 2gb or better) and the effects slider turned to 3 and the rest maxed (seems to fix all the lag in the unoptimized areas like blue mountain) the game engine is very smooth and almost flawless
invizo Xfire Miniprofile