Trending Games | WildStar | World of Warcraft | ArcheAge | Elder Scrolls Online

  Network:  FPSguru RTSguru
Login:  Password:   Remember?  
Show Quick Gamelist Jump to Random Game
Members:2,736,524 Users Online:0
Games:713  Posts:6,174,716
Hanbit Soft
MMORPG | Genre:Fantasy | Status:Cancelled  (est.rel 06/12/09)  | Pub:Atlus Online
PVP:Yes | Distribution:Download | Retail Price:n/a | Pay Type:Free | Monthly Fee:n/a
System Req: PC | ESRB:TOut of date info? Let us know!

NeoSteam Forum » General Discussion » used key and now no server?

3 posts found
  joker007mo

Novice Member

Joined: 8/08/09
Posts: 720

 
OP  2/17/10 10:30:31 AM#1

i decided to give the game a go and use the key provided from this site i did made an acct installed patched and when it loads login screen says no server found

i try to log in to the website again (it was already logged in when i registered) and password is wrong it says and some error occured when i tried to go to the forums so any ideas as to what is going on?

 

  kigiin75

Novice Member

Joined: 2/15/09
Posts: 3

2/18/10 3:42:17 PM#2

 yo, did you activate account? check mail!

  joker007mo

Novice Member

Joined: 8/08/09
Posts: 720

 
OP  2/20/10 9:01:20 AM#3
Originally posted by cezar96

 yo, did you activate account? check mail!

 

yes actually i did it logged me in that night and after i had to refresh in the morning i was logged out and it says incorrect password plus when i start up the client instead of a log in screen says no server found and closes the client