Trending Games | Elder Scrolls Online | Marvel Heroes | Guild Wars 2 | World of Warcraft

  Network:  FPSguru RTSguru
Login:  Password:   Remember?  
Show Quick Gamelist Jump to Random Game
Members:2,736,252 Users Online:0
Games:712  Posts:6,173,824
Funcom | Play Now
MMORPG | Genre:Fantasy | Status:Final  (rel 05/20/08)  | Pub:Eidos Interactive
PVP:Yes | Distribution:Download | Retail Price:n/a | Pay Type:Free | Monthly Fee:n/a
System Req: PC | Out of date info? Let us know!

Age of Conan Forum » General Discussion » Quitting Age of Conan, Not happy about this.

7 posts found
  Foreverdream

Spotlight Poster

Joined: 8/30/10
Posts: 91

 
OP  2/09/13 11:05:02 AM#1

Man...

I really, really do enjoy playing this game. It is unique MMO and still stands toe to toe with current and coming MMO's. 

 

My problem is simple really, I don't want to quit but funcom is literally driving away there customers! Ever since i purchased my 660ti's it is unplayable. I crash randomly, and can also munipulate it. At first i thought the GPUs itself was going bad...it wasn't...it was merely the shitty coding on funcom end. All my other games work fine. I played battlefield 3 this morning for 4 hours, no crash! Then ran heaven on extreme tess 8xaa and had avg 57fps 39/121 (min/max).  Far cry 3, perfect.

Can't stomach buying  ati cards if when ive had no problems with these. Only with AoC

 

I think i will wrap up my journeys and tie off with the community. It was a good one though!

IF YOU'RE A KIND HUMAN PLEASE HELP. If you can't, At least share it on FB! Thanks

http://www.gofundme.com/New-Horizons

  proxy42086

Novice Member

Joined: 8/31/09
Posts: 29

2/09/13 11:09:18 AM#2

newer cards tend to have less support on older games.

 

  Po_gg

Elite Member

Joined: 5/12/10
Posts: 1950

2/09/13 11:09:38 AM#3
Strange, AoC (and TSW as well) is part of the nVidia camp... did you ask the tech support? Maybe they could help somehow.
  Mdpats

Apprentice Member

Joined: 5/12/08
Posts: 179

2/09/13 2:57:03 PM#4
This is strange.  I'm running an Evga SC GTX660 3GB and I can run it with no problems at all.  Have you tried turning the settings down to see what happens?
  platonicx

Novice Member

Joined: 7/12/12
Posts: 22

2/09/13 3:03:37 PM#5

For every person having problems like you There is about 20 with no problems. you shodnt drop to conclusions like "but funcom is literally driving away there customers" .

Chances are whatever the problem is its solvable on your end. So i suggest you explore that option.

 

  syntax42

Elite Member

Joined: 3/30/07
Posts: 1072

2/09/13 3:05:11 PM#6
Originally posted by Foreverdream

Ever since i purchased my 660ti's it is unplayable.

Does the poor attempt at a plural word mean you are using two graphics cards in SLI?  

 

Many games do not support SLI.  I would suggest checking for others who may have reported issues with SLI.  The simple solution then, would be to force the game to use only one video card.

  WalterWhite

Hard Core Member

Joined: 4/25/08
Posts: 401

It's time to cook.

2/09/13 3:06:42 PM#7
I logged in to AoC a few days ago after a long time away and everything was fine. Tinker with your settings a bit and maybe you might sort it out but it isn't helpfull to others that may be able to offer you suggestions unless you post your PC specs.