Trending Games | Kyn | Shroud of the Avatar | Guild Wars 2 | World of Warcraft

    Facebook Twitter YouTube
Login:  Password:   Remember?  
Show Quick Gamelist Jump to Random Game
Members:3,024,390 Users Online:0
Games:841  Posts:6,480,176
Artifact Entertainment | Official Site
MMORPG | Setting:Fantasy | Status:Final  (rel 12/08/03)  | Pub:Virtrium
Distribution:Download | Retail Price:Free | Pay Type:Subscription
System Req: PC | ESRB:TOut of date info? Let us know!

3 posts found

Apprentice Member

Joined: 12/07/10
Posts: 1

OP  12/14/10 8:46:59 PM#1

*Sighs* I've tried reloading it multiple times and redownloading it 2 times already (It took 24 hours to download) When i log in and click play, the launcher comes up and plays for littereley 1 second then closes itself with no error message. It's frusterating! I think my inernet service causing this because not so long ago, Istaria had worked. (Cricket Broadband) Istaria works perfectly on my Grandma's computer. Anyway to fix this?... :/ 

A heart of flames, a soul of ash, a breath of fire, talons of death, fangs of fury, and wings of bravery. No creature on earth could ever outsmart, defeat, or trick a dragon.


Novice Member

Joined: 5/25/06
Posts: 22

12/15/10 2:48:18 PM#2

No offense intended toward the great people on these forums, but this is the sort of thing that should be handled by contacting Vitrium itself via a support ticket.

You would use the same login that you created to access the game to get to support.  The website is


Elite Member

Joined: 7/17/09
Posts: 2954

12/15/10 3:23:46 PM#3

Same thing happened to me yesterday try running it with administrator privileges.

Uploaded with