Trending Games | ArcheAge | WildStar | Elder Scrolls Online | Archlord 2

  Network:  FPSguru RTSguru
Login:  Password:   Remember?  
Show Quick Gamelist Jump to Random Game
Members:2,801,486 Users Online:0
Games:725  Posts:6,196,441
Artifact Entertainment | Official Site
MMORPG | Genre:Fantasy | Status:Final  (rel 12/08/03)  | Pub:Virtrium
Distribution:Download | Retail Price:Free | Pay Type:Subscription
System Req: PC | ESRB:TOut of date info? Let us know!

2 posts found
  deathwisher

Novice Member

Joined: 3/11/04
Posts: 1

 
OP  5/02/08 11:30:03 PM#1

I have tried to log into the game via the website login. But whenever I try to log into the game it starts to load and then it seems like its done loading and just stops. The game never pops up, it never takes me into the actual game. I have tried this for a couple of hours now, tried to find some way to fix it on the support site and nothing seems to work.

Any help would be appreciated with this. Thanks in advance.

  Orlena

Novice Member

Joined: 5/25/06
Posts: 22

5/03/08 5:56:37 AM#2

There are two options here if you have a character created already.

1) There is a launcher in your install folder that you can use instead of the website.  It should say HorizonsLauncher.exe.

2) You can use IE and try changing various check boxes.  For example, if .NET is checked, uncheck it.  Or vice versa.  Some people find help one way, some another, and I can't seem to remember which is which.

If you have no characters, right now you're stuck with just the internet explorer option, I'm afraid.  That's currently the only way to create a new character.

If none of these things works, submitting a support ticket should get you a response and some help from CS.  I've found them to be pretty prompt in their responses, or you could post on their forums and get help from the player community there.